570 lemon?

bill luke

Member
Joined
Nov 6, 2006
Messages
52
I wonder what would cause a machine to be labeled,"a lemon"..does multiple and constant issues make it a lemon.im curious ,many issues with mine,as with others
 

FredC

Village Idiot
Joined
Jul 13, 2011
Messages
15,309
not likely....but I'm not a lawyer

I doubt it qualifies as a consumer product (or farm machinery in some states).
Your machine is beyond the warranty right (6 years old?)?
Lemon law/mmwa is a warranty act.

If it did qualify was there an actual breach of the warranty ?

multiple and constant doesn't necessarily mean lemon

Is this an attempt to get a current issue resolved?
 

Mark Saiger

Mr Happy!
Joined
Dec 26, 2006
Messages
10,906
Location
Grand Rapids, MN
Name
Mark Saiger
With my van, it was considered a Commercial Vehicle....so no lemon law would apply....to get a lemon law would have been and taken a different avenue.

I know of one person who did get the commercial version of lemon law applied to his van....but he lost a ton of money, no credit for his wrap...and everything was still a pain in the rear...

(PS....I hate my local GM dealership for being a bunch of putz's causing all my trouble)

Find a fix, or trade it off would be my thoughts....it sometimes isn't worth all the headaches of complaining about something that doesn't work for you.....my experience anyway...
 

bill luke

Member
Joined
Nov 6, 2006
Messages
52
not likely....but I'm not a lawyer

I doubt it qualifies as a consumer product (or farm machinery in some states).
Your machine is beyond the warranty right (6 years old?)?
Lemon law/mmwa is a warranty act.

If it did qualify was there an actual breach of the warranty ?

multiple and constant doesn't necessarily mean lemon

Is this an attempt to get a current issue resolved?
 

SamIam

Supportive Member
Joined
Aug 9, 2012
Messages
8,598
Location
California
Name
sam miller
My ignition wire was loose no juice.

Took it in an edit started the tightened up the key housing no problem since.


My tech uses this machine and beats it up.

I said if you see anything loose tell me.

He said oh ya that's started getting loose a couple days ago.
 
  • Like
Reactions: Chris A

bill luke

Member
Joined
Nov 6, 2006
Messages
52
With my van, it was considered a Commercial Vehicle....so no lemon law would apply....to get a lemon law would have been and taken a different avenue.

I know of one person who did get the commercial version of lemon law applied to his van....but he lost a ton of money, no credit for his wrap...and everything was still a pain in the rear...

(PS....I hate my local GM dealership for being a bunch of putz's causing all my trouble)

Find a fix, or trade it off would be my thoughts....it sometimes isn't worth all the headaches of complaining about something that doesn't work for you.....my experience anyway...
Probably more of a pain in the rear,than a lemon. Maybe a poor choice of wording.gonna take it in. By the way, p lime is great
 

bill luke

Member
Joined
Nov 6, 2006
Messages
52
My ignition wire was loose no juice.

Took it in an edit started the tightened up the key housing no problem since.


My tech uses this machine and beats it up.

I said if you see anything loose tell me.

He said oh ya that's started getting loose a couple days
 

bill luke

Member
Joined
Nov 6, 2006
Messages
52
I thought it was the waste tank float,again,but its somewhere in the wire from the connector it wont bypass with jumpers,,,have talked with chuck from sapphire ,just no fix yet thanks
 
  • Like
Reactions: SamIam

Doug Cox

Supportive Member
Joined
Dec 17, 2006
Messages
4,511
Location
Delavan, WI
Name
Doug Cox
It won't bypass what? Do you mean the diverter doesn't open and close? Are you in a hot climate? Have you done the water box upgrade?
 
  • Like
Reactions: Mikey P

bill luke

Member
Joined
Nov 6, 2006
Messages
52
It won't bypass what? Do you mean the diverter doesn't open and close? Are you in a hot climate? Have you done the water box upgrade?
The waste tank float, I've had upgrades done ,its going to jon don ,,see what they come up with. Thanks
 

Doug Cox

Supportive Member
Joined
Dec 17, 2006
Messages
4,511
Location
Delavan, WI
Name
Doug Cox
So you're saying its a lemon because the float doesn't work. I'll take that problem all day long if thats all I have to deal with. My machine has shut down twice maybe because of the tank filling in 4 years.
 

Matt Wood

MLPW
Joined
Feb 4, 2016
Messages
7,136
Location
Georgia
So you're saying its a lemon because the float doesn't work. I'll take that problem all day long if thats all I have to deal with. My machine has shut down twice maybe because of the tank filling in 4 years.
No, he's saying it's showing similar symptoms of a bad waste tank float that isn't the problem. That's the way I understood it
 

Jim Martin

Supportive Member
Joined
Oct 7, 2006
Messages
10,703
Location
Arizona
Name
Jim Martin
could be the way it is wired..is the float breaking the power...or is it breaking the ground...

did they wire it to normally open...or did they wire it to normally closed...
 

SamIam

Supportive Member
Joined
Aug 9, 2012
Messages
8,598
Location
California
Name
sam miller
I thought it was the waste tank float,again,but its somewhere in the wire from the connector it wont bypass with jumpers,,,have talked with chuck from sapphire ,just no fix yet thanks
I've had several wire problems and it usually was the by pass switch a relay went bad and a wire came loose.

I have to drive an hour to have someone look at mine.
 

SamIam

Supportive Member
Joined
Aug 9, 2012
Messages
8,598
Location
California
Name
sam miller
My ignition wire was loose no juice.

Took it in an edit started the tightened up the key housing no problem since.


My tech uses this machine and beats it up.

I said if you see anything loose tell me.

He said oh ya that's started getting loose a couple days ago.

I had that pro1200 check engine light for bank 1,3,5,7 open injector so it runs in safe mode or dummy mode.

Had it a a local shop 10 days I told him bad wiring bad injector or bad ecm. Monday he said it's inthe working first injector so getting 12 volts. Havent heard from him since.

I really don't know what to do anymore.
 

Jim Martin

Supportive Member
Joined
Oct 7, 2006
Messages
10,703
Location
Arizona
Name
Jim Martin
I had that pro1200 check engine light for bank 1,3,5,7 open injector so it runs in safe mode or dummy mode.

Had it a a local shop 10 days I told him bad wiring bad injector or bad ecm. Monday he said it's inthe working first injector so getting 12 volts. Havent heard from him since.

I really don't know what to do anymore.

just a thought..but...has anyone checked to see if there is a power loss to the transmission...if for some reason there is a power loss... they go into limp mode...they may be looking in the wrong spot...could be a simple speed sensor that is doing it.....
 
  • Like
Reactions: SamIam

Top Bottom