The 370 has been extra hot lately...

Papa John

Lifetime Supportive Member
Joined
Aug 19, 2013
Messages
4,769
Location
San Francisco, CA.
Name
John Stewart
My unit is over heating and shutting down even when waterbox/heat exchanger has water flow.
It only happens when temperature thermostat is on.
Filter is clear.
I think the Bimba needs to be lubed.
Any suggestions
 
Joined
Dec 20, 2006
Messages
1,047
Location
cape coral fl.
I got HOT today working on 2nd floor then no water from wand engine running fine, Ran down to hose and someone turned if off, The temp gauge was past 240 no water just steam. I stopped the unit and nothing but steam from the hose. lost track of time probably 5-8 minutes running no water. After 10 min. I restarted and no problem all is fine back to work. I had the customer stay at the hose so that I could finish. Thats my old Cobb 2045 can't kill it. Just another great day on the job. jz.
 
  • Like
Reactions: Cleanworks

Cleanworks

Supportive Member
Joined
Oct 22, 2012
Messages
21,105
Location
New Westminster,BC
Name
Ron Marriott
I got HOT today working on 2nd floor then no water from wand engine running fine, Ran down to hose and someone turned if off, The temp gauge was past 240 no water just steam. I stopped the unit and nothing but steam from the hose. lost track of time probably 5-8 minutes running no water. After 10 min. I restarted and no problem all is fine back to work. I had the customer stay at the hose so that I could finish. Thats my old Cobb 2045 can't kill it. Just another great day on the job. jz.
I've had people do that before.
 

Latest posts

Top Bottom